Mengatasi Error Must Have a TTY to Run Sudo Saat Install Zimbra di CentOS 7

 

Dapatkan update terbaru Linuxku.com di kanal Telegram https://telegram.me/linuxkudotcom.

“sorry, you must have a tty to run sudo zimbra centos”

Pesan error diatas seringkali muncul pada saat proses instalasi LDAP zimbra. Ini disebabkan oleh adanya proses pengeksekusian sudo oleh user zimbra tanpa login secara normal terlebih dahulu (melalui tty). Oleh karena itu kita perlu mengedit salah satu opsi pada file /etc/sudoers untuk menonaktifkan fitur “Pengeksekusian Sudo harus melalui TTY terlebih dahulu”. Ketikkan perintah berikut :

 # visudo  

Kemudian carilah baris :

 Defaults  requiretty  

Berilah tanda pagar didepan baris tersebut sehingga menjadi seperti ini :

 #Defaults  requiretty  

Jika sudah simpan file tersebut.

Setelah itu jalankan kembali installer zimbra kalian. Seharusnya sudah tidak akan muncul error yang serupa.

Semoga bermanfaat 🙂

Tinggalkan Balasan

Alamat email Anda tidak akan dipublikasikan. Ruas yang wajib ditandai *